Difficultés d’installation sur LibreOffice/OpenOffice

Modifié le  Fri, 27 May 2022 sur 01:23 PM

Si aucun message d’erreur n’apparait lors de l’installation de LanguageTool sur LibreOffice/OpenOffice, mais que vous doutez de son bon fonctionnement, veuillez consulter le document suivant et suivre les instructions.


Problèmes fréquents

  • LibreOffice propose son propre correcteur intégrer de grammaire (LightProof). Celui-ci désactive LanguageTool pour l’Anglais et le Russe. Allez dans Options → Paramètres de langues → Aides d’écriture → Modifier… pour désactiver LightProof et activer LanguageTool pour votre langue de travail. 
  • Vérifier l’installation d’une version Java 8 ou plus et sélectionnez sur LibreOffice (Outils  → Options → Avancées) ou OpenOffice.org (Outils→ Options → Java). Pour les utilisateurs de Mac : LibreOffice (Préférence → LibreOffice → Avancées).
  • Si vous avez une version 32-bit de LibreOffice/OpenOffice, vous devrez aussi posséder la version 32-bit de Java – sinon LanguageTool sera incompatible. Apache OpenOffice ne propose pas encore de versions 64-bit pour Windows et Mac, vous devrait donc installer Java 32-bit sur Mac et Windows.
  • Le message “Téléchargement de Java impossible” apparait : si vous rencontrez ce problème sur Windows 64-bit, cela peut être lié à la version 64-bit de Java. Apache OpenOffice sur Windows est seulement créé comme une application 32-bit et sera incompatible avec Java 64-bit. Vous devrez utiliser une version 32-bit de Java pour Windows. (OOo bug #118346). Toujours en quête d’une solution, essayez ces suggestions.


Autres types d’erreurs

  • Lors de l’installation, si vous obtenez “Ce type de média est incompatible : application//vnd.sun.star.package-bundle2.0.00", veuillez reparamétrer votre profil utilisateur d'OpenOffice.
  • Si vous obtenez une erreur indiquant “accès mémoire invalide”, vérifiez que LanguageTool est installé dans votre chemin d’accès sans caractères spéciaux (utilisez uniquement a-z, A-Z et 0-9).
  • Si vous obtenez : “Erreur du chargement des règles pour la langue… Causé par java.lang.ClassNotFoundException:Erreur de chargement des règles: Duplicate class definition” : Pour une raison quelconque, LanguageTool est déjà installé comme extension LibreOffice/OpenOffice.org. Vous pouvez essayer de la désinstaller des dossiers listés dans le message d’erreur après avoir effectué une sauvegarde. (Les dossiers à supprimer ont des noms quelconques comme "EE31.tmp_" ou semblable — quittez LibreOffice/OpenOffice.org avant d’effacer le moindre fichier.)


Toujours en quête d’une solution, publiez un commentaire sur le forum dérivant le problème et indiquez-nous la version de LanguageTool utilisé,LibreOffice/OpenOffice.org avant de supprimer le moindre fichier.

Cet article a-t-il été utile ?

C'est super !

Merci pour votre commentaire

Désolé ! Nous n'avons pas pu vous être utile

Merci pour votre commentaire

Dites-nous comment nous pouvons améliorer cet article !

Sélectionner au moins l'une des raisons
La vérification CAPTCHA est requise.

Commentaires envoyés

Nous apprécions vos efforts et nous allons corriger l'article